跳转到内容

其他任务 (microDisplay X)#

设置用户偏好#

您可以在 microDisplay X 中设置影响以下内容的参数:

  • microDisplay X 的 GUI 显示(applet 显示以及参数值的十进制/十六进制/二进制显示)
  • 采集参数(缓冲区数量、采集超时、最大 DMA 缓冲区大小)
  • 相机检测和相机控制的行为

要设置使用 microDisplay X 的首选项:

  1. 在 microDisplay X 中,从 Tools 菜单选择 Settings。
  2. 在打开的对话框中,调整您想要更改的设置:

    • Applet 显示: 单击 GUI,以及在 Applet 布局 / 视图模式,决定 Applet 在程序窗口的 Applet 布局窗格中的显示方式。选择是将 Applet 的资源(端口)按进程(Process Mode)还是按资源类型(Resource Mode)列出:
      • 在 process mode 下,属于一个进程(一个采集通道)的资源(端口)在 Applet 布局窗格中作为实体 Acquisition Process 列出。
      • 在 resource mode 下,在 DMAs 下列出了所有活动的 DMA 端口(加载到 microDisplay X 中的 Applet 的端口)。在 Camera Ports 下列出了连接到相关采集卡的所有相机。
    • 默认整数显示模式:对于程序窗口中的参数和像素值显示,您可选择十进制、十六进制和二进制。
    • 采集参数:若要设置采集参数,请单击 Acquisition 并定义您的偏好:

      采集参数

    • 发现设置:若要设置发现参数,请单击 Discovery 并定义您的偏好:

      发现参数

保存 Applet 配置#

配置完小程序后(在 microDisplay X 中或通过 Framegrabber API),您可以保存配置。

保存小程序配置后,下次加载小程序(在采集卡上、microDisplay X 和/或您的软件中)时,所有参数都将保持已设置状态。

信息

请确保在保存和使用小程序配置时使用相同的 Framegrabber SDK 版本。例如,如果您使用 Framegrabber SDK 5.9.0 版本配置并保存了小程序配置,则应仅在 5.9.0 版本的环境中加载该配置。

以下章节提供了使用 MCF 文件所需的所有信息。

MCF 和 MFS 文件#

MCF 文件#

保存 Applet 配置时,配置数据将保存到文件中。配置文件具有文件扩展名 *.mcf。(MCF = microEnable Configuration File)

MCF 文件以文本格式保存,因此您不仅可以通过 microDisplay X 或 API 修改各个参数的设置,还可以直接在该文件中进行修改。

MCF 文件示例

MCF 文件包含:

  • 其所属的小程序名称。
  • 您所做的所有参数设置(唯一例外:字段值)。
  • 如果需要,指向 MFS 文件的链接(其中包含您在小程序配置期间定义的字段值)。

在单独的 XML 文件中配置相机

MCF 文件不包含相机配置。您可以将相机配置保存在单独的 *.xml 文件中。MCF 文件仅包含小程序配置。

MFS 文件#

Applet 的配置可能包含场参数,例如 LUT。这些场参数不直接存储在 MCF 文件中,而是存储在文件扩展名为 *.mfs 的独立文件中。(MFS = microEnable Field Storage)

您永远无需直接处理 MFS 文件:

  • 如果您的小程序配置包含字段参数,则在保存小程序配置时,MFS 文件将与 MCF 文件一起自动创建。
  • 加载小程序配置时,只需加载 MCF 文件即可,因为 MFS 文件的内容(字段参数)将与 MCF 文件一起自动加载。

信息

每款采集卡均可免费使用一组 Applet。这些 Applet 称为 Acquisition Applets。所有 Acquisition Applets 的文件扩展名均为 *.dll。Acquisition Applets 以 Applet 集的形式提供(每个采集卡型号对应一个)。Applet 集可以随 Framegrabber SDK 一起安装,也可以通过单独的 Applet 集安装程序进行安装(可在 Basler 网站的下载专区获取)。安装后,Acquisition Applets 位于 Framegrabber SDK 安装目录下的 Dll 子目录中。(例如:C:\Program Files\Basler\FramegrabberSDK5.x.x\Dll。)Acquisition Applets 可在可编程和不可编程采集卡(即 A 系列和 V 系列采集卡)上运行。

所有 Acquisition Applets 都包含域参数。因此,每次保存 Acquisition Applet 的配置时,都会创建两个文件:*.mcf 文件和 *.mfs 文件。但是,您无需单独处理 *.mfs 文件,因为它在您保存/加载 *.mfs 文件时会自动创建/加载。

以下数组(域参数)是所有或部分 Acquisition Applets 的组成部分:

  • LUTs
  • KneeLUTs
  • PoCXPStatePort_x(仅限 marathon CXP 板卡)
  • PoCXPCurrentPort_x(仅限 marathon CXP 板卡)
  • PoCXPVoltagePort_x(仅限 marathon CXP 板卡)

信息

将所有域数据保存在单独的文件中可使 Applet 配置文件 MCF 保持简洁,并可实现向下兼容。

在 microDisplay X 中进行保存和加载#

在 microDisplay X 中将 Applet 配置保存到文件#

在 microDisplay X 中,您可以将当前加载的 Applet 的配置保存到文件。

  1. 从文件菜单中,选择保存配置。

    microDisplay X:保存配置

  2. 选择要存储 Applet 配置文件 (*.mcf) 的目录。

  3. 为您的 *.mcf 文件命名。
  4. 点击保存。

*.mcf 文件将被创建并存储在您在第二步中指定的目录中。如果 Applet 配置包含域值,则会创建一个附加的 *.mfs 文件,其中包含 Applet 配置的所有域参数值。如果 Applet 包含域参数,MFS 文件将自动创建。

在 microDisplay X 中从文件加载 Applet 配置#

  1. 在 microDisplay X 中,选择您要在其上使用所配置 Applet 的采集卡。

    microDisplay X:选择采集卡

  2. 从文件菜单中,选择打开配置。

    microDisplay X:打开配置

  3. 在打开的对话框中,导航到包含您的 Applet 配置的目录。

  4. 选择您要使用的 *.mcf 文件,然后点击打开。

配置好的 Applet 将加载到 microDisplay X 中并在采集卡上激活。如果 Applet 配置包含场参数,系统将自动从相应的 *.mfs 文件中加载场值。您无需单独加载 *.mfs 文件。

通过 Framegrabber API 进行保存和加载#

通过 Framegrabber API 将 Applet 配置保存到文件#

为了保存 Applet 配置文件,Framegrabber API(库 fglib5.lib,头文件 basler_fg.h):

int Fg_saveConfig (Fg_Struct *Fg, const char *Filename)

参数:

  • Fg:您系统中的采集卡(板卡索引)。在此指定您要从中保存活动配置(活动 Applet 及其参数化)的采集卡。
  • Filename :在此指定配置文件的工作路径和名称。文件扩展名始终为 *.mcf。

如果 Applet 配置包含域值,则会创建一个附加的 *.mfs 文件,其中包含 Applet 配置的所有域参数值。如果 Applet 包含域参数,MFS 文件将自动创建。

通过 Framegrabber API 从文件加载 Applet 配置#

要从文件中加载小程序配置,可以使用各种函数(库)。 fglib5.lib,头文件 basler_fg.h):

采集卡初始化#

您可以通过 *.mcf 文件直接初始化开发板。由于 MCF 文件包含小程序名称,因此帧采集卡会使用 MCF 文件中指定的小程序进行初始化,并且存储在 *.mcf 文件中的小程序配置(参数化)已应用于帧采集卡。

如果您的小程序配置包含字段参数,并且相应的 *.mfs 文件与 *.mcf 文件存储在同一目录中,则在调用此函数时会自动加载字段参数。

Fg_Struct* Fg_InitConfig (const char * Config_Name, unsigned int BoardIndex)

参数:

  • Config_Name:在此指定配置文件的工作路径和名称。文件扩展名始终为 *.mcf。
  • BoardIndex在此处(通过其板卡索引)指定要使用 *.mcf 文件初始化的图像采集卡。调用后 Fg_InitConfig帧捕获器使用 *.mcf 文件中命名的 applet 和同一文件中指定的 applet 配置进行初始化。
加载 Applet 配置#

您也可以在用小程序初始化帧捕获器之后加载小程序的配置。

使用此功能的先决条件:

  • 帧捕获器已通过函数初始化。 FG_Init 或者作为一位大师 FG_InitEx.
  • 存储在 *.mcf 文件中的小程序配置适用于帧采集器初始化时使用的小程序。(如有疑问,请查看 *.mcf 文件。小程序名称位于 *.mcf 文件的第一行。)

如果您的小程序配置包含字段参数,并且相应的 *.mfs 文件与 *.mcf 文件存储在同一目录中,则在调用此函数时会自动加载字段参数。

帧捕获器初始化后加载小程序配置的函数:

int Fg_loadConfig (Fg_Struct *Fg, const char *Filename)

参数:

  • Fg:在此处指定要使用 *.mcf 文件中包含的小程序配置进行参数化的帧捕获器(通过板索引)。
  • Filename:在此指定配置文件的工作路径和名称。文件扩展名始终为 *.mcf。

信息

使用帧捕获器后,不要忘记通过函数释放帧捕获器的资源。

int Fg_FreeGrabber (Fg_Struct *Fg)

此函数还会释放之前通过以下方式为该帧捕获器分配的帧缓冲区: Fg_AllocMem().