跳转到内容

软件安装 (blaze)#

本主题介绍如何安装 Basler blaze-101 相机所需的软件。

You need to install the following software components:

  • pylon Camera Software Suite (version 6.2 or higher)
  • pylon Supplementary Package for blaze

The software is available for the following operating systems:

  • Windows
  • Linux x86_64

You can download the software from the Basler website.

软件安装 (Windows)#

To install the blaze software:

  1. Download the following installers from the Basler website:
    • Basler_pylon_version.exe
    • pylon_Supplementary_Package_for_blaze_version.exe
  2. Navigate to the folder to which you downloaded the installers and double-click the Basler_pylon_version.exe file.
    The pylon Setup Wizard opens.
  3. Accept the license agreement and click Next.
  4. On the Profiles page, select the Developer profile and click Next.
  5. On the Interfaces page, select the GigE interface and click Next.

    信息

    Choosing the "Custom" Profile Option

    If you prefer to choose the software components to be installed individually, select the Custom option in step 4 (Interfaces page) of the procedure above. If you do, you have to select the following options on the Features page:

    • pylon Runtime
    • GigE Camera Support
    • GenTL Consumer Support
    • SDKs
  6. On the Destination Folder page, you can change the default install location by clicking Change and choosing the desired folder. When you're happy with the install location, click Next.

  7. Review the settings and click Install when you're ready.
    The installation starts. A message will inform you when the installation has been completed successfully. The start menu will now contain a Basler folder.

  8. Navigate to the folder to which you downloaded the installers and double-click the pylon_Supplementary_Package_for_blaze_version.exe file.

  9. Follow the instructions of the wizard to complete the installation.
    A message will inform you when the installation has been completed successfully.

软件安装 (Linux)#

信息

On Debian-based systems (like Ubuntu), Basler recommends downloading and installing the Debian packages (.deb) of the pylon Camera Software Suite and the pylon Supplementary Package for blaze.

For other Linux distributions, download the .tar.gz archives.

Ubuntu and Other Debian-Based Distributions#

信息

There are two versions of the installation packages. If you are going to perform the installation on Ubuntu 18.04 or above, use the pylon-supplementary-package-for-blaze-version-amd64.deb package. The pylon-supplementary-package-for-blaze-version-amd64_no_viewer.deb package is supported for Ubuntu 16.04 or above. However, it doesn't include the blaze Viewer tool.

To install the blaze software:

  1. Download the following packages from the Basler website:
    • pylon_version-deb0_amd64.deb
    • pylon-supplementary-package-for-blaze-version_amd64.deb or pylon-supplementary-package-for-blaze-version_amd64_no_viewer.deb
  2. Install the pylon Camera Software Suite using the pylon_version-deb0_amd64.deb package.
  3. Install the pylon Supplementary Package for blaze by issuing one of the following commands:

    sudo apt-get install ./pylon-supplementary-package-for-blaze-*version*_amd64.deb
    

    sudo apt-get install ./pylon-supplementary-package-for-blaze-*version*_amd64_no_viewer.deb
    

Linux Distributions Not Based on Debian#

To install the blaze software:

  1. Download the following archives from the Basler website:
    • pylon_version_x86_64_setup.tar.gz
    • pylon-supplementary-package-for-blaze-version_x86_64_setup.tar.gz
  2. Extract the pylon_version_x86_64_setup.tar.gz archive and follow the instructions in the INSTALL document included in the archive.
  3. Extract the pylon-supplementary-package-for-blaze-version_x86_64_setup.tar.gz archive.
  4. Change to the extracted directory and extract the pylon-supplementary-package-for-blaze-version_x86_64_setup.tar.gz archive to /opt/pylon.

示例:

tar xf pylon-supplementary-package-for-blaze-*version*-amd64.tar.gz
cd pylon-supplementary-package-for-blaze-*version*-amd64
sudo tar -C /opt/pylon -xzf ./pylon-supplementary-package-for-blaze-*version*-amd64.tar.gz

If the tools and libraries contained in the pylon-supplementary-package-for-blaze-version_x86_64_setup.tar.gz archive don't work on your system due to missing dependencies, try the pylon-supplementary-package-for-blaze-version_x86_64_setup_no_viewer.tar.gz archive. The binaries in that archive are built using an older toolchain. However, this archive doesn't contain the blaze Viewer.

后续步骤#

继续进行硬件安装

返回顶部