使用 Framegrabber SDK 配置 CXP 线扫描相机和采集卡#
有关要求和可能的拓扑结构的信息,请参阅 General Information。
安装 Framegrabber SDK#
需要管理员权限
要在计算机上安装 Framegrabber SDK,您需要具备管理员权限。
若要安装 Framegrabber SDK 以配合 Basler racer 2 相机使用:
- 下载 Framegrabber SDK 5.11.2 或更高版本。
- 启动安装程序并按照提示完成安装。
- 在 Select Components 对话框中,选择 Full installation,并确保在组件列表中选中了 GenTL Producer。

有关详细的安装说明,请参阅 Basler 产品文档中的 Installing the Framegrabber SDK 主题。
microDisplay X 入门#
-
若要首次查看图像,请打开 microDisplay X。
-
配置一些基本设置,以便简化使用 Basler racer 2 相机的图像采集过程:
- 在 工具 > 设置 > Acquisition,将 Number of Buffers 更改为
100下设置。这使您能够浏览已采集的图像,对于相机校准非常有用。 -
设置 将 Acquisition Timeout
1000 s设为较高的值(例如)。这对于设置触发以及避免超时是必不可少的。
-
在 Tools > Settings > Discovery 下,选中 Autoconnect discovered cameras 复选框。

- 在 工具 > 设置 > Acquisition,将 Number of Buffers 更改为
-
在 microDisplay X 中加载 Applet。请参见可能拓扑以了解您的设置需要哪个 Applet。

-
双击 Applet 名称。此时将使用您的 Applet 配置采集卡 FPGA。
-
由于您已选择 Autoconnect discovered cameras,相机现在应该已连接:

-
现在,您可以通过单击 Applet Layout 窗格中的 DMA 0 或 Cam 0,在相机、采集卡或接口卡的参数之间进行切换。如果您已将多个相机连接到单个或多个采集卡或接口卡,则可以在此处选择相机和 DMA 通道。
- 根据需要配置相机和采集卡或接口卡。
-
重要的采集卡或接口卡参数必须与相机设置相匹配。这些参数包括:
- CoaXPress > Pixel Format
- ROI > Width
- 对于 ROI > Height,请定义所需的图像高度。此参数值定义输出图像的相机行数。

-
要开始图像采集,请切换到 Acquisition Channel 或 Viewing 窗格,然后单击
Play 按钮。 -
microDisplayX 可协助您设置采集卡 ROI。对于线扫描相机,请单击 Ignore。

只要相机和采集卡或接口卡处于自由运行模式,您现在就可以看到相机图像。

使用 CoaXPress 行触发#
若要使用 CoaXPress 行触发器,请将相机设置为 CoaXPress Trigger Mode,并按如下方式配置相机和采集卡或接口卡:
在配置参数前停止图像采集
在配置任何参数设置之前,必须停止图像采集。否则,某些参数将无法编辑。
- 在 Applet Layout 窗格中,选择 Cam 0。
-
在 Parameter Selection 窗格的 Acquisition Control 下,设置以下参数:
Trigger Mode=OnTrigger Source=Cxp Trigger 0

默认情况下,采集卡使用周期为 200 µs 的内部发生器。若要更改源或使用 轴编码器,请选择 DMA 0 或 Applet Layout 窗格并为您的硬件设置配置 Line Trigger / ExSync 参数: 
有关参数的详细说明,请参考 imaFlex CXP-12 Quad、imaWorx CXP-12 Quad 以及 CXP-12 Interface Cards 的小应用程序文档。
曝光模式 Trigger Width 和 Trigger Controlled#
要使用外部信号控制 Exposure Time,您可以使用两种 Exposure Modes Trigger Width 和 Trigger Controlled.
- 使用
Trigger Width如果您将触发信号直接连接到相机的 I/O。 - 使用
Trigger Controlled如果使用 CXP 触发数据包且触发信号通过相机传输。
Exposure Mode Trigger Width#
要使用 Exposure Mode Trigger Width,您必须在相机中设置以下参数:
- 要切换到此 Exposure Mode,请将相机参数
Exposure Mode=Trigger Width. - 要配置触发,请设置以下参数:
Trigger Selector=Line StartTrigger Mode=OnTrigger Source设置为您连接触发器的 I/O,例如Line1.- 如果您有反转信号,则可以按需设置
Trigger Activation=Falling Edge.
在 Exposure Mode Trigger Width下,相机直接使用来自 I/O 的触发信号,而不是通过 CXP。因此,如果您选择了此 Exposure Mode Trigger Width.

Exposure Mode Trigger Controlled#
要使用 Exposure Mode Trigger Controlled,您必须在相机中设置以下参数:
- 要切换到此 Exposure Mode,请将相机参数
Exposure Mode=Trigger Controlled. -
要配置触发,请设置以下参数。这将通过 CoaXPress 触发器启动和结束曝光:
Trigger Selector=Exposure StartTrigger Mode=OnTrigger Source=Cxp Trigger 0.

Trigger Selector=Exposure EndTrigger Mode=OnTrigger Source=Cxp Trigger 1.

现在,您必须配置采集卡以生成 Cxp Trigger 0 和 Cxp Trigger 1 触发数据包。您有以下三种选项:
- 默认情况下,使用内部发生器:

- 如果更改
LineTriggerMode参数至Async Gated Trigger,您可以使用 I/O 信号来控制曝光时间:
- 或者,您可以将 I/O 信号直接旁路到
CXP Link Trigger 0和CXP Link Trigger 1以控制曝光的开始和结束:
检查图像#
microDisplay X 提供了多种方法来检查采集的图像。当您想要校准相机时,以下项目会很有帮助:
- Line Histogram 视图
- Line Profile 视图
- 翻阅获取的图像序列
- 获取像素值或放大每个像素
- 保存当前图像或图像序列
有关详细信息,请参阅 Basler Product Documentation 中的 Examining Images 主题。
复制代码#
要将配置复制到您的 SDK 程序中,请选择任意参数的 Details 并复制代码。

或者,您可以在 microDisplay X 中保存配置文件并在 SDK 程序中加载它。有关详细信息,请参阅 Basler Product Documentation 中的 Saving Applet Configuration 主题。
对于 GenTL 使用,请遵循相同的参数配置。您可以在 %GENICAM_GENTL64_PATH% 目录中找到 GenTL Producer。