跳转到内容
STAGING SERVER
DEVELOPMENT SERVER

相机标定#

本主题解释了为什么需要进行标定,以及如果出厂标定遭到损坏时如何对相机进行标定。

要将相机用作测量仪器,必须准确了解相机的各项参数,例如焦距、镜头畸变以及各个相机之间的相对关系。这些参数通过标定确定,并用于图像矫正,这是所有后续图像处理的基础。Stereo ace 相机根据相机的标定自动矫正图像。

Stereo ace 相机在生产过程中已经过标定。如果 Stereo ace 相机受到强烈的机械外力作用(例如跌落),则可能需要重新标定。如果您发现相机突然无法再输出任何 3D 数据,则说明可能需要重新标定。

Self-Calibration#

Stereo ace 相机具有自标定模式,该模式在后台以低频率运行。在此模式下,相机可观察两个已矫正图像中线条的对齐情况。机械冲击(例如相机跌落)可能会导致不对齐。如果检测到明显的对齐偏差,系统会自动对其进行修正。

要启用自标定,请将 BslSelfCalibration acquisition mode On.

该值 BslSelfCalibrationUpdateCounter 参数在每次自动修正后都会增加。对相机进行手动重新标定后,该参数将重置为 0.

在正常情况下(例如 Stereo ace 相机未受到机械冲击),自标定不应发生。自标定允许 Stereo ace 相机即使在检测到对齐偏差后也能正常运行,因为系统会自动对其进行修正。不过,如果出现以下情况,Basler 建议手动重新标定相机: BslSelfCalibrationUpdateCounter 参数 0.

Manual Calibration#

在手动标定时,必须在不同的姿势下检测到标定板。握持标定板时,请确保标定板的所有黑色方块在两幅相机图像中均完全可见且未被遮挡。正确检测到的方块会获得一个绿色勾选标记。必须正确检测到所有黑色方块,以确保标定正常进行。如果部分方块根本未被检测到或仅被短暂检测到,原因可能是光照条件不佳或标定板损坏。标定板过曝光区域中的方块将以红色高亮显示。在这种情况下,您必须调整光照条件或曝光设置。标定板周围粗大的绿色边框表示它在两幅相机图像中均被正确检测到。

将标定板持于相机前方,确保标定板的所有黑色方块在两幅相机图像中均完全可见且未被遮挡。正确检测到的方块会获得一个绿色勾选标记。必须正确检测到所有黑色方块,以确保标定正常进行。如果部分方块仅被短暂看到或根本未被检测到,原因可能是光照条件不佳或标定板损坏。标定板过曝光区域中的方块将以红色高亮显示。在这种情况下,您必须调整光照条件或曝光设置。标定板周围粗大的绿色边框表示它在两幅相机图像中均被正确检测到。

可以使用 Stereo Calibration Tool 执行手动标定。从 pylon 3D Viewer 中点击 Tools > Stereo Calibration Tool 来启动该工具。该工具针对标定的各个步骤设有不同的选项卡。这些步骤将在下文中详细介绍:

  • 初始设置
  • 调整对焦
  • Verify Calibration
  • Calibrate
  • Monocalibration
  • Calculate
  • 保存

初始设置#

要开始标定过程,您必须选择相机和标定板。

  1. 在 pylon 3D Viewer 的 Tools 菜单中,点击 Stereo Calibration Tool 以启动该工具。
  2. 在 Stereo Calibration Tool 的 File 菜单中,点击 Connect Camera。
    随即会打开 Select Camera 对话框。可用相机将自动列于其中。
  3. 选择所需的相机。
  4. 在 Calibration Grid 下拉列表中,选择所需的标定板。
  5. 单击确定。

Stereo Calibration Tool - Select Camera 对话框

Verify Calibration#

现在,您可以验证当前的标定。典型的标定误差低于 0.2 像素。如果您相机的显示误差在此范围内,您可以退出标定过程。如果标定误差较大,您应继续进行标定过程,以确保最佳的相机性能。

要进行验证,请将标定板持于相机前方,使两台相机能够同时看到它。一旦检测到标定板,就会自动计算标定误差,并将结果显示在屏幕上。

如果您想继续进行标定,请点击 Calibrate。

Stereo Calibration Tool - 验证标定步骤

信息

为了计算出有意义的标定误差,标定板应尽可能靠近相机。如果标定板仅占据相机图像的一小部分,则其标定误差总是会比标定板占满整个图像时低。因此,除了当前标定板位置处的标定误差外,还会显示验证过程中的最小和最大标定误差。

Calibrate#

在开始标定之前,请指定合适的 Exposure Time。为了获得良好的标定结果,图像应曝光良好并避免运动模糊。因此,在能够保证场景良好曝光的前提下,Exposure Time 应尽可能短。

完整标定包括对每台相机分别进行标定(单相机标定),以及执行双目立体标定以确定相机之间的几何关系。在大多数情况下,每台相机的内参标定保持不变。因此,在重新标定时,默认会跳过单相机标定,但可以通过点击 Monocalibration 按钮来执行该操作。

在立体标定过程中,对两台相机进行相互标定,以求出它们的相对旋转和平移关系。

首先,应将标定板尽可能靠近相机并保持静止。它必须在两幅图像中完全可见,并且相机应垂直正对标定板。如果标定板未垂直于相机的视线,指向标定板角点预期位置的小绿色箭头将予以提示。

Stereo Calibration Tool - 标定步骤

标定板必须保持绝对静止。如果出现运动模糊,则无法检测到标定板。绘制在图像上的所有标定网格单元必须全部被标定板覆盖。系统会通过将覆盖的单元填充为绿色来可视化这一状态。

一旦所有网格单元都被覆盖,它们就会消失,并显示一个单独的远端单元。现在,应将标定板尽可能远离相机,以便覆盖该小型单元。箭头将指示标定板是否仍然距离相机太近。当在远端姿态成功检测到标定板后,该单元将被填充为绿色,并且可以计算结果。

如果立体标定产生令人不满意的标定误差,您应先执行单相机标定,然后再重复立体标定。

Monocalibration#

单相机标定是对每台相机分别进行的内参标定。由于内参标定通常保持不变,因此只有在立体标定结果不理想时才需要执行单相机标定。

进行单相机标定时,必须将标定板以特定姿态持于相机前方。标定板角点处指向绿色区域的箭头表示所有角点都应放置在绿色区域内。这些绿色区域被称为敏感区域。可以通过 Size of Sensitive Area 滑块来控制它们的大小,以简化标定。但是,请注意,将其尺寸放大过多可能会导致标定精度略有下降。

Stereo Calibration Tool - 单相机标定步骤

单相机标定过程涉及每台相机的五个姿态。将标定板的角点或边缘放置在敏感区域上方后,该过程会自动显示所需的下一个姿态。左侧相机的过程结束后,对右侧相机重复相同的步骤。

Calculate#

点击 Calculate 按钮即完成该过程,并显示最终结果。显示的结果是所有标定点的平均重投影误差。该误差以像素为单位,通常小于 0.2。

Stereo Calibration Tool - 计算步骤

保存#

立即点击 Save 以应用标定并将其保存到 Stereo ace 设备中。