跳转到内容
STAGING SERVER
DEVELOPMENT SERVER

pylon 3D Viewer 概述#

本主题为您概述 pylon 3D Viewer 的用户界面,该界面支持诸如 blaze、Stereo ace 和 Stereo mini 等 Basler 3D 相机。

以下截屏显示了 pylon 3D Viewer 的不同元素。

pylon 3D Viewer 用户界面

应用程序布局包含以下主要区域:

  • 菜单栏
  • 多个工具栏
  • 位于左侧和右侧的可停靠窗格
  • 包含 2D 和 3D 子窗口的图像窗口区域
  • 底部的状态栏

“文件”菜单#

文件菜单提供以下命令:

  • Save Depth and Image Data (Ctrl+S):将深度和图像数据以及相机设置保存到文件。有多种格式可供选择。有关详细信息,请参阅 Saving Depth and Image Data。
  • Exit (Ctrl+Q):关闭 pylon 3D Viewer。

“视图”菜单#

使用 View 菜单可显示或隐藏 UI 元素。该菜单是动态生成的,包含以下项的切换开关:

  • 工具栏(例如 Camera Selector、File、Camera Control、Point Picking)
  • 窗格(例如 Camera Features、Pixel Information、Documentation、Message Log、Depth Histogram、Depth Line Plot)

“相机”菜单#

相机菜单提供以下命令:

  • Rescan: 更新可用相机列表。
  • Open (Ctrl+O):打开所选相机。
  • Close (Ctrl+L):关闭活动相机。
  • Continuous Shot (F7):开始连续采集。
  • Stop (F8):停止图像采集。
  • Automatic Image Adjustment: 自动设置相机参数并调整深度范围。此功能仅适用于支持的相机型号和功能。
  • Save Features: 将当前相机 Property 设置保存到 .pfs 文件中。保存前必须停止图像采集。
  • Load Features: 从先前保存的 .pfs 文件中加载相机 Property 设置。

“工具”菜单#

Tools 菜单允许您访问以下命令。根据相机型号和安装情况,某些项可能不可用。

  • pylon IP Configurator:启动用于 GigE 设备的外部 IP 配置工具。
  • pylon GigE Optimizer:打开针对 GigE Vision 相机的网络优化对话框。
  • Stereo Calibration Tool:启动外部立体标定工具。
  • Toggle Pick Mode (Alt+P):在单点和双点拾取模式之间切换。

“窗口”菜单#

使用 Window 菜单创建和排列图像窗口。

该菜单通常包含以下部分:

  • 2D 视图
  • 3D 视图
  • 窗口排列与导航

可用命令包括:

  • 新建深度图视图
  • 新建置信度图视图
  • 新建强度图像视图
  • 新建点云视图
  • Open
  • 全部关闭
  • 平铺
  • 层叠
  • 下一步
  • 上一个

在分隔线下方,菜单会显示当前打开的子窗口编号列表。处于活动状态的子window会被标记。

“帮助”菜单#

Help 菜单可让您访问文档和支持功能。根据相机型号的不同,并非所有条目都可用。

  • pylon 3D Viewer Help(F1):打开查看器文档。如果选中了某项 Property,将打开该 Property 的上下文相关帮助内容。
  • Basler Product Documentation: 打开所连接相机的产品文档。
  • Programmer's Guide: 打开所连接相机型号的程序员指南。
  • Open Samples Directory: 打开包含编程示例的文件夹。
  • Check for Software Updates: 打开 Basler 软件更新下载页面。
  • Check for Firmware Updates: 打开 Basler 固件更新下载页面。
  • Update Camera Firmware: 在浏览器中打开相机固件更新页面(仅支持的型号)。
  • Download DiagnosticInfo.tar.gz: 从相机下载诊断包(仅支持的型号)。
  • Show Release Notes: 打开本地发行说明(如果可用)。
  • About pylon 3D Viewer: 打开包含版本和许可证信息的对话框。

工具栏#

相机选择器工具栏#

包含一个相机选择下拉菜单,其中列出了当前检测到的所有设备。

文件工具栏#

包含一个用于保存深度和图像数据的 Save 按钮。

相机控制工具栏#

提供对相机命令的快速访问:

  • Open
  • Open
  • 连续拍摄
  • 停止
  • 自动图像调节

点选取工具栏#

包含用于在单点和双点拾取之间切换的 Toggle Pick Mode。

窗格#

相机功能#

Camera Features 窗格显示所选相机的 GenICam 特性树。

典型用法:

  • 展开和折叠特性类别。
  • 选择一个特性以在 Documentation 窗格中显示上下文文档。
  • 按 ++F1++ 获取特定于特性的帮助。
  • 读取和编辑特性(在采集期间可能会限制编辑)。

像素信息#

Pixel Information 窗格显示所选点的位置和深度相关值。

在单点模式下,该窗格显示一个所选点的值。

在双点模式下,该窗格还会显示两点之间的差值(例如 dX, dY, dZ)以及欧几里得距离。

有关详细信息,请参见 Image Windows。

文档#

Documentation 窗格显示在 Camera Features 窗格中选择的特性的上下文相关信息。

消息日志#

Message Log 窗格显示带有严重级别和时间信息的应用程序消息,例如:

  • 信息
  • 警告
  • 严重

这对于排查连接、采集和配置问题非常有用。

深度直方图#

Depth Histogram 窗格显示活动场景当前的深度值分布(直方图)。

深度折线图#

Depth Line Plot 窗格可视化显示两个所选点之间连线上的深度剖面(双点模式)。

根据您的首选显示方式,可以使用可选的 Invert Depth Axis 设置。

图像窗口区域#

图像窗口区域包含 2D 和 3D 子窗口。默认情况下,查看器会打开一组标准的窗口。

典型的默认视图包括:

  • 强度图像视图
  • 深度图视图
  • 点云视图

窗口布局按相机类型进行存储。重新连接同一相机系列时,将恢复先前的布局。

所有窗格都可以通过 View 菜单进行停靠、取消停靠、隐藏和恢复。

视图#

点云视图 (3D)#

以 3D 点云形式显示深度数据。

常用选项:

  • 色彩模式
  • 显示坐标轴

可用的色彩包括(具体取决于相机型号和数据):

  • 白色
  • 强度
  • 距离
  • Z 轴
  • 置信度颜色
  • 强度颜色

深度图视图 (2D)#

以 2D 图像形式显示距离/深度图。

常用选项:

  • 色彩
  • 深度范围滑块

典型色彩:

  • 灰度
  • 彩虹色

置信度图视图 (2D)#

以灰度图像形式显示置信度值。

强度图像视图 (2D)#

显示相机的强度或红外图像通道。可用通道取决于相机型号。

典型通道包括:

  • 左侧强度
  • 右侧强度
  • 组合强度
  • 左侧红外
  • 红外右

其他 Viewer 功能#

点选取#

该查看器支持在 2D 和 3D 视图中进行点拾取。

  • 单点模式:选择一个点以检查其值。
  • 双点模式:选择两个点以比较值和距离。

快捷键:

  • Alt+P:切换单点/双点模式。
  • Alt+C:清除已拾取的点。

自动图像调节#

自动图像调节 分析当前场景并在连接的相机支持时自动设置合适的深度范围(DepthMin, DepthMax)。

状态栏#

状态栏显示运行时信息,例如:

  • 当前 FPS
  • 延迟(因型号而异)
  • 帧 ID
  • 连接 Quality 指示器

布局持久化#

该查看器可存储并恢复其窗口布局。

  • 窗格的位置和可见性
  • 打开 2D/3D 视图及其排列方式
  • 视图特定设置

布局按相机类型进行存储,从而能够在不同的相机系列之间快速切换。