分层框

HierarchicalBox运算符是其中的一种特殊运算符。 VisualApplets 它允许对设计进行结构化处理。顾名思义,该运算符具有框的功能。您可以标记设计的一部分,并将其作为层级框的内容。

层级框在设计中以运算符实例( HierarchicalBox运算符)的形式显示。您可以在单独的设计窗口中查看和编辑层级框的内容。

层级框包含运算符和链接的组合,并且可以将它们连接到任意数量的输入和输出链接。使用层级框模块可以实现以下功能:

  • 你的设计结构必须非常清晰,并且

  • 管理模块组。

在设计面板中, HierarchicalBox模块显示为 M 型运算符(椭圆形);然而,它的行为取决于层次框内的运算符。

下图展示了一个层级框的示例。如图所示,层级框中包含的操作符显示在单独的设计窗口中。根据窗口设置,这两个图表可以同时查看,如示例所示。有关如何排列图表窗口的更多信息,请参阅VisualApplets的用户界面” 。

层级框示例

图 45. 分层框示例


创建分层框

添加层级框有多种方法:

  • 将设计的一部分做成层级框:

    1. 选择要组装成层级盒状的设计模块。(按键盘上的 STRG 键,然后单击要组装的模块。)

    2. 按住 STRG 键,然后在设计窗口的空白处单击鼠标右键,打开上下文菜单。

    3. 从上下文菜单中,选择“移动到分层框” 。

      创建一个新的层级框,其中包含所有选定的模块以及相应的入站和出站链接。

    4. 双击层级框,打开显示层级框实现的图表窗口。

  • 定义一个空的层级框:

    1. 从基础库中选择HierarchicalBox运算符并将其添加到您的设计中,或者

      在图表中的空白区域单击鼠标右键,然后选择“插入” → “层次结构框” ,或者

      从主菜单中选择“设计” → “分层框” ,或者

      选择图标 表格中显示 编辑 工具栏。

    2. 在弹出的窗口中,定义新HierarchicalBox的输入和输出链接的数量。

    3. 单击 OK。

      HierarchicalBox模块已插入到您的图表中;它具有您刚刚指定的输入和输出端口数量。

    4. 双击层级框模块,打开其设计窗口。

    5. 在层级框中添加您想要的运算符。

    6. 将盒子里的设计件通过连接线连接到盒子的输入和输出端口。

在设计 Windows 之间导航

返回到包含层级框模块的流程设计窗口:

  1. 在设计窗口中,点击“窗口”选项卡:

    设计窗口的窗口选项卡

    图 46. 设计窗口的窗口选项卡


退后一步,回到原有的层级:

  1. Select 看法 → 车窗升起 ( Backspace )或点击 车窗升起 按钮 表格中显示 看法 工具栏。

编辑模块 Property

打开模块属性:

  1. 右键单击层次结构框,然后从上下文菜单中选择“属性”。在这里,您可以查看和编辑层次结构框中可用于参数化的参数。

有关如何使深层嵌套在受保护的分层框(或属于另一个受保护的分层框的受保护的分层框)中的参数在此级别可见和可用的信息,请参阅“操作符参考”库“参数”。

复用分层框

您可以通过复制粘贴多次使用层级框。每个层级框实例都独立于其同级实例​​,也就是说,如果您更改其中一个复制的层级框,这不会影响其他实例。

有关如何使用分层框作为库元素和受保护库元素的信息,请参阅“创建用户库元素”部分。

向分层框中插入附加端口

您可以随时为您的分层设备添加更多输入和输出端口。要添加端口:

  1. 导航至显示分层框模块的设计窗口。

  2. 将鼠标指针移至输入端口(如果要插入输入端口)或输出端口(如果要插入输出端口),使该端口高亮显示。

    突出一个港口

    图 47. 突出显示端口


  3. 右键单击端口。

  4. 从上下文菜单中,选择“在上方插入端口”或“在下方插入端口” 。

新端口已插入,并已分配默认名称。要为端口指定自定义名称,请使用上下文菜单项“重命名端口” (见下文)。

删除分层框的端口

您可以随时删除分层设备的输入或输出端口。要删除端口:

  1. 导航至显示分层框模块的设计窗口。

  2. 将鼠标指针移到要删除的端口上,使其高亮显示。

  3. 右键单击端口。

  4. 从上下文菜单中,选择“移除端口” 。

端口已删除。

重命名分层框的端口

为了提高设计的可读性,您可以为分层框的输入端口和输出端口命名:

  1. 导航至显示分层框模块的设计窗口。

  2. 将鼠标指针移到要重命名的端口上,使其高亮显示。

    突出一个港口

    图 48. 突出显示端口


  3. 右键单击要重命名的端口。

  4. 从上下文菜单中,选择“重命名端口” 。

  5. 在“重命名端口”对话框中,输入端口的名称。

    输入端口名称

    图 49. 输入端口名称


  6. 单击 OK。

例如,在层级框模块的设计窗口中可以看到新名称:

重命名分层盒子的端口

图 50. 分层盒的重命名端口


重新排序分层框的端口

与重命名类似,您可以重新排列分层盒模块的端口顺序:

  1. 导航至显示分层框模块的设计窗口。

  2. 将鼠标指针移到要更改位置的端口上,使其高亮显示。

    突出显示端口

    图 51. 突出显示端口


  3. 右键单击要重新排序的端口。

  4. 从上下文菜单中,选择“上移端口”或“下移端口” 。

端口顺序已互换。例如,在分层盒模块的设计窗口中可以看到这一点:

重新排列分层盒的输入端口

图 52. 分层盒的重新排序输入端口


端口顺序的重新排列不会影响层级式盒子的功能。重新排列后的端口与之前相同的内部和外部设计元素相连。