主程序窗口

VisualApplets 提供了一个用于设计 applet 的图形用户界面。 无需编写脚本,也无需编写任何程序代码。 该用户界面非常简单,专为用户轻松上手而设计。 无需具备编程技术背景。

VisualApplets 主程序窗口由多个栏和面板组成:

主程序窗口

图 11. 主程序窗口


主菜单栏提供对程序功能的直接访问。 使用工具栏按钮可以快速访问重要功能。您可以在 Settings → System Settings → Common 中更改工具栏图标的大小:

三个面板提供了不同的信息和功能:

  • 设计面板:设计面板显示您的 VisualApplets 项目。 您始终拥有一个主设计窗口,但根据项目的结构,您可能还需要处理 多个子窗口。 在 Window 菜单中,可以选择多种视图(平铺、层叠、标签页视图)。 使用位于 Window → Diagram Windows( Ctrl+F8 )中的菜单项, 您可以轻松选择当前要处理的设计图表窗口。

  • 信息面板: 在主程序窗口的默认设置中,信息面板始终显示。 它以标签页视图提供不同的信息窗口:

    • 项目信息

    • 模块信息

    • 参数信息

    • DRC 日志

    • 生成日志

    • 帮助

    (有关各个信息窗口的详细信息,请参见下文。)

  • 库面板:在主程序窗口的默认设置中,库面板始终显示。 它以标签页视图提供三个库窗口:

    • Operator Library:Operator Library 是包含 VisualApplets 算子(即各个 图像处理函数)的子库集合。

    • User Library:User Library 可以包含带有用户定义的算子组合(分层框)的自定义库。 有关详细信息,请参阅 'User Libraries'。

    • Custom Library:要将算子导入 Custom Library,您需要 Expert 许可证或 VisualApplets 4 许可证。

[提示] 特定算子

算子库中显示的某些算子可能不适用于您当前正在为其进行设计的平台。 如果不适用于您选择的平台,该算子将显示为灰色。

算子不适用于当前选定的目标硬件平台

图 12. 不适用于当前所选目标硬件平台的算子


Information Panel 窗口

项目信息

“Project Info”(项目信息)窗口概括了当前项目的信息。

项目信息

图 13. 项目信息


提供以下信息:

  • Name(名称):项目名称(= 文件名)

  • Creation Date(创建日期):创建日期

  • Last Modified(最后修改):最后修改日期

  • 版本:项目的版本号;可以从 Design → Project Details 菜单 (另请参阅 'Project Properties')中编辑此条目

  • 描述:项目的文字描述;可以从 Design → Project Details 菜单 (另请参阅 'Project Properties')中编辑此条目

  • 类型:显示目标硬件当前使用的 FPGA 类型 (另请参阅 'Target Hardware Porting')

  • Target Runtime(目标运行时):显示目标运行时(参见 'Target Runtime')

  • Design Rules Check Level 1:指示发现的错误或成功的性能 (另请参阅 'Design Rules Check')

  • Hardware Applet:指示是否存在硬件 applet。 如果 VisualApplets 先前已生成该项目的 HAP 文件,则会选中此条目。

  • Resources(资源):显示资源估计的结果。另请参见 'FPGA Resource Estimation'。

  • 系统:显示找到的 XILINX 版本、可用的 Framegrabber SDK 版本以及 Framegrabber SDK 安装目录。 VisualApplets 使用此信息来构建 HAP 以及用于最终的 HAP 输出。 有关详细信息,请参阅 'Build'。

模块信息

Module Info 窗口显示项目中使用的所有模块的列表(只要该窗口的输入字段为空)。 该列表按项目的层级结构组织。

模块搜索

图 14. 模块搜索


在 Module Info 窗口中,您可以轻松搜索特定模块或模块类型。这在处理 大型设计时非常有用。 在开始搜索之前,您应该定义过滤设置:

  • 如果要搜索您赋予模块的单独名称,请激活“Names”。

  • 如果要搜索模块类型(您当前正在搜索其实例的算子的名称), 请激活“Types”。

模块搜索

图 15. 模块搜索


您现在可以输入搜索字符串。只需输入名称的一部分即可。 点击 Module Info 窗口中列出的某个模块,即可将相应的设计窗口带入焦点(在设计面板中), 同时该模块将被选中并高亮显示。

参数信息

The Parameter Info view shows all parameters and their operators of the active design. You can also edit the parameters in the Parameter Info view.

参数信息

图 16. Parameter Info


The Parameter Info view provides a search function that allows you to search for parameters, parameter values, or operator names. You can use the Runtime Parameter Only filter to display only the dynamical parameters, i.e. parameters that you can edit during runtime.

DRC 日志

DRC Log 窗口显示上次设计规则检查的结果。 点击警告/错误消息下列出的某个模块名称,即可将相应的设计窗口带入 焦点(在设计面板中), 同时该模块将被选中并高亮显示。

DRC Log 信息

图 17. DRC Log 信息


生成日志

Build Log 窗口显示了最后一次构建的结果。

Build Log 信息

图 18. 构建日志信息


帮助

Help 窗口提供有关各个算子的上下文相关帮助。

要打开上下文相关帮助,您可以执行以下操作之一:

  1. 直接在您的设计中选择您想要获取信息的算子,然后按 F1 打开并在 Help 窗口中显示相应的信息。

  2. 从 Operator Library 窗口中选择一个算子。 Help 窗口将始终显示当前所选内容的帮助。

示例:显示 MergeKernel 算子的信息

图 19. 示例:显示 MergeKernel 算子的信息


如果您在任何其他窗口中按 F1 或点击帮助按钮,将打开当前所选窗口或功能的上下文相关用户手册帮助。 当然,您也可以直接从本文档访问算子帮助。请参阅 Operator Reference。

Library Panel 窗口

库面板以标签页视图显示 Operator Library 窗口、User Library 窗口和 Custom Library 窗口。

所有库(Operator Library、User Library 以及包含其所有子库的 Custom Library)均以树状结构组织。 每个库都包含算子。

可以通过选择“树状”、“列表”或“图标”视图来更改结构的显示方式。

显示 Operator Library 的库面板

图 20. 显示 Operator Library 的库面板


可以在搜索字段中输入搜索字符串,以过滤列表,仅显示所需的算子。 例如,输入 Camera 将列出名称中包含 camera 的所有算子。

算子库

Operator Library 是包含 VisualApplets 算子(即各个图像处理函数)的子库集合。

您可以通过点击 Operator Library 窗口中的算子名称并点击信息面板中的 Help 标签页,来获取有关每个算子的详细信息。

显示 Operator Library 的库面板

图 21. 显示 Operator Library 的库面板


有关如何向图表中添加新算子的信息,请参阅 'Inserting Operators'。 所有算子的详细文档均在 Operator Reference 中给出。

用户库

User Library 可以包含带有用户定义的算子组合(分层块)的自定义库。 有关更多信息,请参阅 'User Libraries'。

自定义库

要将算子导入 Custom Library,您需要 Expert 许可证或 VisualApplets 4 许可证。

调整主程序窗口

您有多种选项可用于根据个人偏好调整 VisualApplets 的主程序窗口:

调整工具栏

可以通过拖放重新排列工具栏,或者通过右键单击来添加/删除工具栏。

恢复主程序窗口的默认设置

如果您不小心以不希望的方式排列了窗口或工具栏,可以通过以下方式恢复默认设置 窗口 → 重置停靠窗口 ( Ctrl+O ) 或通过点击相应图标 在 View 工具栏中。

“文件 -> 最近的设计”下的文件数量

在 File → Recent Designs 下,VisualApplets 会向您展示最近打开过的 VisualApplets 文件 (*.va) 列表。您可以配置实际显示的 文件数量。

若要定义显示多少个最近打开的文件:

  1. 转到菜单 Settings → System settings 并选择 Common 类别。

  2. 在 Recent designs 下,定义您希望显示的文件数量(最多 24 个)。

  3. 点击 Ok 确认。

配置显示最近设计的数量

图 22. 配置显示最近设计文件的数量